[Debian/PPC] Segfault when running dbus-monitor

Olivier Andrieu oliv__a at users.sourceforge.net
Fri Oct 1 10:26:41 UTC 2004

 > Bryan Bulten [Thu, 23 Sep 2004]:
 > Recently install dbus on my Debian/PPC system.

Which version was that ?

 > However, when I run dbus-monitor (from user or root account) I get the
 > following:
 > [root at norwood][139]% dbus-monitor --system                              
 > 6659: arguments to dbus_connection_send_with_reply_and_block() were
 > incorrect, assertion"(error) == NULL || !dbus_error_is_set ((error))"
 > failed in file dbus-connection.c line 1999. 
 > This is normally a bug in some application using the D-BUS library.
 > Failed to set up match "dbus-monitor": � 
 > zsh: 6659 segmentation fault 
 > dbus-monitor --system[root at norwood][139]% 
 > Perhaps this problem has been fixed in CVS, I didn't notice anything
 > in the ChangeLog.  Any ideas?

Not really. Did you try with a CVS version ? If you still get a
segfault, try to get a stacktrace.


More information about the dbus mailing list