python bindings & gmainloop

Sean Meiners sean.meiners at
Mon Sep 19 11:18:26 PDT 2005

Good news.  0.50.0 (plus figuring out how to make the gmainloop use threads 
properly) seems to have completely solved the problem.  Sorry for the trouble 

PS: I would have tried upgrading sooner, but a cursory glance at the python 
bindings in CVS didn't look all that much different from 0.35.2.  Guess they 
were just different enough.

On Friday 16 September 2005 10:54 am, Sean Meiners wrote:
> I've got 0.35.2 currently.  I'll update it and let you know what happens.
> On Friday 16 September 2005 10:44 am, John (J5) Palmieri wrote:
> > Oh, also, what version of d-bus are you using? Versions previous to 0.50
> > could crash when using threads because of a problem with the way Pyrex
> > handles the GIL.
> >
> > On Thu, 2005-09-15 at 15:01 -0700, Sean Meiners wrote:
> > > Ok, so I finally figured out how to get gmainloop to play nice with
> > > other threads, only to expose an even more interesting problem.  When
> > > my test script is run (attached) it causes a 'Fatal Python error:
> > > PyThreadState_Get: no current thread' as soon as the gmainloop is
> > > entered, but only if threading has been initialized and you actually
> > > connect to a bus (system or session, it makes no difference). Now
> > > here's the really interesting part: it all works fine if I undo your
> > > EmptyMessage patch (diff attached).

Sean Meiners
sean.meiners at

Perl - $Just @when->$you ${thought} s/yn/tax/ &couldn\'t %get $worse;

More information about the dbus mailing list