[Fwd: Re: [gphoto-devel] EOS 350D capture]

oliver frommel oliver at firstfloor.org
Tue Dec 19 04:41:04 PST 2006


here I forward a post from the gphoto2 mailing list with a problem
concerning D-Bus on Fedora. Some comments are below the quoted
passage ..

> I finally tried that with the 2.3.0 release. Configured with 
> "--with-drivers=canon" and the above define. However when I tried
> "gphoto2 --auto-detect" the program crashed with an assertion
> "!_dbus_transport_get_is_connected". After some searching on the
> web I recompiled libgphoto2 with an additional line in 
> libgphoto2_port/disk/disk.c. Before "dbus_connection_unref()" in 
> line 192 I added "dbus_connection_disconnect (dbus_connection)" -
> without knowing what I actually do. But I figure it's probably 
> better to first close the connection before unreferencing it.

For better readybility, here's my change again
(in libgphoto2/libgphoto2_port/disk/disk.c)

original version (triggers failed assertion)
        libhal_free_string_array (volumes);
        libhal_ctx_free (ctx);
        dbus_connection_unref (dbus_connection);

        libhal_free_string_array (volumes);
        libhal_ctx_free (ctx);
        dbus_connection_disconnect (dbus_connection)
        dbus_connection_unref (dbus_connection);

The guys on the gphoto list told me that it is a Red Hat /
Fedora specific problem probably. Because my change fixes
the problem but "you cannot .. disconnect, someone else
still might be listing". So what's the correct solution to
cope with that on Fedora?


More information about the dbus mailing list