[patch] break glib bindings by adding timeout_milliseconds
david at fubar.dk
Wed Mar 1 09:01:53 PST 2006
On Wed, 2006-03-01 at 11:19 +0100, Thiago Macieira wrote:
> David Zeuthen wrote:
> >I don't really like magic numbers such as -1 or -2 so I would prefer b.
> >. Realistically, though, we probably want to go for a. and also add
> >symbolic constants
> > #define DBUS_TIMEOUT_DEFAULT -1
> > #define DBUS_TIMEOUT_FOREVER -2
> >or something. Sure, it's more typing but, eh, the -1 in most uses of
> >dbus_connection_send_with_reply just seems to magical.
> How about 0?
> Making a blocking call that doesn't wait has no meaning. You cannot get an
> instantaneous reply anyways.
Yea, 0 instead of -2 sounds like a much better idea to me.
More information about the dbus