SELinux and libdbus-java-1.9.tar.gz

Matthew Johnson dbus at
Tue Sep 5 03:17:07 PDT 2006

Hash: SHA1

On Mon, 4 Sep 2006, Guy Delamarter wrote:

> I am using the Java bindings for dbus to do what I thought was a
> straightforward acquisition of data from the HAL, but while I get an
> interface for the specific device, invoking any form of GetProperty on
> the device results in an exception explaining that a SELinux-based
> denial of the method call has occurred.  The "view" tool included in the
> libdbus-java tarball emits a similar exception.

I don't *think* this is a problem with the Java bindings, it sounds like
a restriction on what messages can be sent across the system bus to
those Hal object, although I haven't really done anythingwith the
SELinux support.

> My experience comes from using the Python bindings for dbus under Fedora
> Core 5, and I have not run into such a purported SELinux problem before.
> What experiments would be helpful to resolve this?  Is it more a matter
> of placing special contexts on various object files to get this to work?
> Or write new SELinux rules?  I would be surprised that this problem
> isn't already well understood, but I haven't managed to find anything.

Have you tried to call the same method from python before? First thing
to check is if that or just dbus-send produces the same error (which I'd
expect). If it does then it's some sort of SELinux configuration rule or
a rule from the D-Bus system bus config directory/file. I don't really
grok those though.

> I can repost this to an appropriate mailing list if you tell me which
> one that would be.

I've CC'd this to dbus at, hopefully someone there
can answer this better.


- -- 
Matthew Johnson
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Made with pgp4pine 1.76


More information about the dbus mailing list