Issues while using DBUS over TCP

remya soman remyasomancs at
Sun Jul 27 22:20:58 PDT 2008


I am trying to use dbus over TCP for communication between applications
running on two different machines. At the server, I started the dbus-daemon

*dbus-launch –config-file=Session-local.conf*.

The confiiguration file *Session-local.conf *entries are:





*<policy context="default">*

*<!-- Allow everything to be sent -->*

*<allow send_destination="*"/>*

*<!-- Allow everything to be received -->*

*<allow eavesdrop="true"/>*

*<!-- Allow anyone to own anything -->*

*<allow own="*"/>*

*<!-- Allow any user to connect -->*

*<allow user="*"/>*


*<!-- This is included last so local configuration can override what's *

*in this standard file -->*

*<!-- include ignore_missing="yes">session-local.conf</include-->*


The IP address specified in Session-local.conf* *(, is the
address of the same machine where I have started instance of dbus-daemon.

Then I set the environment variable DBUS_SESSION_BUS_ADDRESS as: *

I set the same value for DBUS_SESSION_BUS_ADDRESS in the other machine and
tried to connect to the dbus.

But I am getting an error in dbus_bus_get call.

The error is *Did not receive a reply. Possible causes include: the remote
application did not send a reply, the message bus security policy blocked
the reply, the reply timeout expired, or the network connection was broken*.

It works fine if I run server and client on the same m/c.

Can anyone suggest a solution to this problem?

Thanks & Regards,

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the dbus mailing list