failed to read machine uuid

Thiago Macieira thiago at
Tue Aug 18 12:11:08 PDT 2009

Steven M. Dodier wrote:
># gimp<br>
>process 26760: D-Bus library appears to be incorrectly set up; failed
>to read machine uuid: Failed to open
>"/usr/packages/dbus10/var/lib/machine-id": No such file or directory<br>
>See the manual page for dbus-uuidgen to correct this issue.<br>
>&nbsp; D-Bus not built with -rdynamic so unable to print a backtrace<br>
>gimp: terminated: Aborted<br>

The machine-id file missing indicates incomplete or corrupted installation.

The path of the file looks also very suspicious. You said that your Gimp is 
located on an NFS mount. Check which system is providing the libdbus-1 
it's linking to: is it your local system or is that coming from the NFS 
mount too?

In any case, the machine-id file should be in your machine, not in the 
mount. So if /usr/packages/dbus10 is in the NFS mount, the path that was 
compiled into the libdbus-1 library is wrong.

You/your admin needs to recompile D-Bus.

>(script-fu:26761): LibGimpBase-WARNING **: script-fu: wire_read():
> error<br> +++++++++++++++++++++=<br>
>I did search you archives and found one hit that said dbus-uuidgen
>needs to be run on the system that is exporting the software, but there

No, it needs to be run on the system that is running the software. 
Usually, it ends up in /var/lib/dbus.

However, running it locally won't help you if the library is looking for 
the file in the wrong path.

>was never a closure on the thread that said that fixed it.&nbsp; While I
> am waiting for the techs that have the power to run the "dbus-uuidgen",
> I wanted to ask for your opinion.&nbsp; Do you believe that is the
> fix?<br> <br>
>Another bit of information is that I can run "dbus-launch gimp", and it
>works fine.&nbsp; Why would that be if the machine-id is still not
> set?<br> <br>

The machine-id file is used by the autolaunch feature of D-Bus. If D-Bus is 
started before gimp, then it won't use autolaunch.

It doesn't mean D-Bus is properly installed. In your case, it isn't. Just 
the fact that the diagnostic wasn't tripped doesn't mean it's all ok. You 
should fix the problem either way.

Thiago Macieira - thiago (AT) - thiago (AT)
  Senior Product Manager - Nokia, Qt Development Frameworks
      PGP/GPG: 0x6EF45358; fingerprint:
      E067 918B B660 DBD1 105C  966C 33F5 F005 6EF4 5358

Qt Developer Days 2009 | Registration Now Open!
Munich, Germany: Oct 12 - 14     San Francisco, California: Nov 2 - 4
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the dbus mailing list