How do I build dbus with x11?

Thiago Macieira thiago at
Mon Nov 30 14:39:43 PST 2009

Em Segunda-feira 30. Novembro 2009, às 23.20.54, luying pan escreveu:
> I'm getting these error messages when running dbus-monitor:
>  dbus-monitor --session
> Failed to open connection to session bus: /usr/local/bin/dbus-launch
> terminated abnormally with the following error: Autolaunch requested, but
> X11 support not compiled in.
> Cannot continue.
> So I'm assuming I didn't install dbus-x11. Is this package built by
> configuring dbus with the --with-x option? Because I can't find the source
> package for it anywhere. But I tried using the --with-x=yes flag when
> running configure in my dbus source directory, however I ended up with a
> configuring that does not build x11.

Yes, that's the option.

Check the rest of your configure output. It tried to find the X11 headers and 
libraries and failed. The config.log file will have all the details.

Thiago Macieira - thiago (AT) - thiago (AT)
  Senior Product Manager - Nokia, Qt Development Frameworks
      PGP/GPG: 0x6EF45358; fingerprint:
      E067 918B B660 DBD1 105C  966C 33F5 F005 6EF4 5358
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the dbus mailing list