Clients seeing EPIPE, dbus-daemon 1.8.16, how to debug?

Chris Morgan chmorgan at
Mon Jun 1 18:21:16 PDT 2015


I'm using dbus-daemon on a systemd distro built under yocto on an arm
system, a BBB (1GHz Arm), 512MB ram, emmc.

At startup we've got two clients, one c# using dbus-sharp, and another
nodejs using node-dbus ( that
are both seeing EPIPE from the dbus client socket as reported via

Another data point is that we have several c/c++ applications using
gdbus that do not see this particular EPIPE issue at startup.

I'm guessing that the high cpu and io load at startup may be the cause
of the issue. Those clients are relatively heavy to startup, one being
mono, the other node. This particular issue isn't seen on the desktop
under F21 or Arch with the same software.

Is there some way to debug the reason behind the EPIPE from the
dbus-daemon side? I tried compiling with the --enable-verbose-tracing
and enabling DBUS_VERBOSE=1 but that produces a ton of output that
seems unrelated to the EPIPE issue.

I've also tried setting <limit name="auth_timeout">120000</limit> in
the system.conf file. I'm not certain it is taking effect but if it is
it still didn't appear to change the behavior.

Does anyone have other thoughts or ideas for how to debug the issue as
to the cause of the EPIPE?


More information about the dbus mailing list