[ *SOLVED* ] RE: launch helper exited with unknown return code 127

Florin Gherendi florin_gf at yahoo.fr
Sun Jun 5 21:19:36 UTC 2016

Hi again!

No answer so far, but I’ve eventually solved the problem by myself. I am posting the solution here cause it was a tricky one.
First: the “Could not connect” message was coming from glib (ugly that it doesn’t say that). Glib does not explicitly require dbus, but it uses some dbus dirs. Therefore I had to patch glib so that it finds the dbus dirs in /opt and not in the root filesystem.
Second: dbus had a problem:  “make install”  wasn’t performing “ldconfig” automatically. That makes dbus-daemon-launch-helper unable to load /opt/usr/lib/libdbus-1.so.3 when running as messagebus user from the libexec dir. This is why dbus-daemon wasn’t launching any service and this is where the error message "launch helper exited with unknown return code 127" was coming from.
I hope this would be useful for someone!

Have a nice time! :)

> -----Original Message-----
> From: Florin Gherendi [mailto:florin_gf at yahoo.fr]
> Sent: Thursday, June 02, 2016 10:13 AM
> To: dbus at lists.freedesktop.org
> Subject: launch helper exited with unknown return code 127
> Hi everyone,
> This is my first message to this list.
> I've compiled and installed dbus 1.10.6 on an ARM DD-WRT WiFi router with
> native gcc (not cross-compiled). All tests pass ok, but my dbus cannot launch
> any service neither in system mode nor in session mode.
> It will always give me "launch helper exited with unknown return code 127"
> when try to launch manually; and as example, for colord, when trying
> "colormgr get-devices" nothing gets logged into syslog, it will only tell me "No
> connection to colord: Could not connect: No such file or directory".
> Could anyone enlighten me about what the signification of the return code
> 127 is?
> Google-ing I can only find bug reports, but no info so far.
> I must say that I modified installation root dir to /opt, since the root
> filesystem is read only; but the config files are all changed accordingly, and
> I've even tried to change the default search dirs in the sources, but with no
> success. The service org.freedesktop.ColorManager (as I was talking about
> colord) is system wide known, cause dbus does not complain about the
> name (it *does* complain if I use an unknown service name), but when I try
> to list all services with "dbus-send --system --dest=org.freedesktop.DBus --
> type=method_call --print-reply /org/freedesktop/DBus
> org.freedesktop.DBus.ListNames" it does not get listed.
> org.freedesktop.ColorManager.service is pointing to the correct location of
> colord (/opt/usr/libexec/colord) and launching /opt/usr/libexec/colord from
> command line doesn't give errors or core dump; but it needs to be launched
> by dbus, which does not happen.
> Where to look for errors?
> Thanks in advance!
> Florin

More information about the dbus mailing list