udisks polling makes LTN403L CD-ROM drive click

Marti Raudsepp marti at juffo.org
Wed Jan 20 03:57:07 PST 2010

On Wed, Jan 20, 2010 at 1:34 PM, Michael Biebl <mbiebl at gmail.com> wrote:
>> On Wed, Jan 20, 2010 at 12:52 PM, Marti Raudsepp <marti at juffo.org> wrote:
>>> Another odd thing about this computer is that Palimpsest lists this
>>> drive directly under "Local Storage", not under a controller. I
>>> haven't seen this on other computers.

> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548758
> http://git.debian.org/?p=pkg-utopia/devicekit-disks.git;a=commitdiff;h=175eecf9f1a924486577698870226e548f76312e

Nope, this is not it. Back when I migrated from devkit-disks, I did
run "/etc/init.d/udev reload", but that didn't help.

Also this does not explain the case of moving my CD-ROM from amd74xx
to pata_amd driver -- there are no udev policy changes, just uevents.

I just tried to reproduce this again; the PATA controller appears in
Palimpsest only after killing udisks-daemon. Isn't it supposed to take
note when udev announces a new controller?

udisks also doesn't notice when I remove it; I run "rmmod pata_amd"
and the CD-ROM disappears, but in Palimpsest still displays a PATA


More information about the devkit-devel mailing list