Why are UPower "Sleeping" and "Resuming" signals not generated?

Vadim Zeitlin vz-freedesktop at zeitlins.org
Wed Jul 18 04:52:11 PDT 2012


 I'm completely new to UPower so sorry in advance if I'm missing something
obvious but could someone please explain why could the "Sleeping" and
"Resuming" signals be not generated? I'm using UPower 0.9.17 under Debian
Wheezy and if I run "upower -m" I never see these signals when suspending
and resuming the notebook (Dell E6500 if it matters). I do get "device
changed" events for battery_BAT0 and line_power_AC devices (and also
"device removed/added" for the former) but nothing else. FWIW I also tested
with dbus-monitor but I don't see these signals in its output neither.

 I've tried suspending the machine in all the different ways I could think
of (sleep button, choosing suspend from the session close dialog, using
"dbus-send org.freedesktop.UPower.Suspend") under all the different
environments installed here (Gnome3, Gnome2, XFCE) with the same [absence
of] result. Why am I not seeing these signals? Where/when exactly are they
supposed to be generated and how can I debug why it doesn't happen?

 Thanks in advance for any help,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/devkit-devel/attachments/20120718/0b56e980/attachment.pgp>

More information about the devkit-devel mailing list