[REGRESSION, i915]: Periodic stalls with 2.6.36-rc2

Peter Stuge peter at stuge.se
Wed Aug 25 12:15:06 PDT 2010

Hello, new on list but not to the kernel. I also have the issue on
ThinkPad X40.

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02) (prog-if 00 [VGA controller])
	Subsystem: IBM Device 0557
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at e0000000 (32-bit, prefetchable) [size=128M]
	Memory at d0000000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [d0] Power Management version 1
	Kernel driver in use: i915

I've been running KMS and drm-intel.git since around 2.6.30, roughly
the start of this year, and I've had lots of "fun" with KMS. :p I'm
very positive to the KMS concept but it's been a bumpy road so far.

In general, Xv performance with KMS leaves me with a feeling that
something is not quite right in terms of playback, both with mplayer
and vlc. But while movies are nice, this stalling issue is more

drm-intel.git as of 07-21 has sortof worked for me, but could not
suspend. Later drm-intel.git would come up with the panel disabled,
so basically make the system unusable. I've been using 07-21 for
about a month, and just avoiding suspending.

I'm now running drm-intel.git/drm-intel-next (which seems to not get
the activity first?) and the latest commit is Linus 2.6.36-rc2. I've
merged wireless-testing.git on top of this for ath9k woes.

I get the stall precisely every 10 seconds. In VT mode the system
stalls for about a second (the cursor stops blinking) and if I'm
typing during the stall then my keypresses appear correctly after the
stall ends. No errors in dmesg. Should I set drm.debug to something?

If I'm running X (I've tried xf86-video-intel 2.12.0 and current .git
master) then my keypresses appear twice after the stall ends, but
honouring shift. If I hold shift, type X, release shift during a
stall then I'll get "Xx" after the stall ends. This makes X
practically unusable for me, so I'm at a plain VT for now.

Suspend works both in VT and in X, so some things have definately
improved for me since 07-21. :)

I've just upgraded my userspace and have xorg-server-1.8.2. No Xv
image with either xf86-video-intel driver. I haven't tried this
server with the 07-21 kernel to find out if Xv works there. The
stalling is more important.

Chris' patch to i915_irq.c disabling wake-ups has no effect on the
stalls in VT mode for me.

I haven't bisected, would that be a big help? I'll probably have to
spend a fair amount of time on that, since the latest previous kernel
I could get to start is over a month old. I've tried drm-intel.git a
couple of times over this month, but for long periods of time there
were no changes. (Should I look elsewhere?)

I also get intermittent FIFO errors, but I don't know how relevant
they are for this issue. It seems like the stalling is a very
distinct issue.

Please let me know how I can help fix this.


More information about the dri-devel mailing list