[Bug 32511] New: glDrawPixels broken on savage

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Dec 19 13:11:57 PST 2010


           Summary: glDrawPixels broken on savage
           Product: Mesa
           Version: git
          Platform: x86 (IA32)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Drivers/DRI/Savage
        AssignedTo: dri-devel at lists.freedesktop.org
        ReportedBy: bugzi09.fdo.tormod at xoxy.net

Created an attachment (id=41267)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=41267)
full backtrace in savageWriteRGBASpan_565()

The drawpix demo draws pixels spread around the screen instead of inside the
window. Each line drawn (194 pixels) get displayed in a cluster, but not as a
line. Only every 6th "line" get displayed, starting from the lower right of the
screen, going left, then up (see drawpix-many.png).

The cluster is divided in 4 squares of 8 times 8 pixels, where the first and
fourth square is not complete. Each square is drawn from left to right, then
from top to bottom. Square are drawn from left to right within a cluster. (See

I have tracked the drawing in mesa down to where it writes each pixel into the
renderbuffer in savageWriteRGBASpan_565(), see the full backtrace in

This is with latest git. I think I have seen similar corruption using the
antspotlight screensaver since a long time ago, and I never tried drawpix
before so this can be an old bug. The bug reporter of the downstream Ubuntu bug
says drawpix worked fine in Ubuntu 8.04 which had mesa 7.0.3.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the dri-devel mailing list