[patch -next] nouveua: sizeof() vs ARRAY_SIZE()
Dan Carpenter
error27 at gmail.com
Mon Dec 20 01:26:26 PST 2010
ARRAY_SIZE() was intended here, sizeof() is too large.
Signed-off-by: Dan Carpenter <error27 at gmail.com>
diff --git a/drivers/gpu/drm/nouveau/nv50_vram.c b/drivers/gpu/drm/nouveau/nv50_vram.c
index 47489ed..58e98ad 100644
--- a/drivers/gpu/drm/nouveau/nv50_vram.c
+++ b/drivers/gpu/drm/nouveau/nv50_vram.c
@@ -42,7 +42,7 @@ nv50_vram_flags_valid(struct drm_device *dev, u32 tile_flags)
{
int type = (tile_flags & NOUVEAU_GEM_TILE_LAYOUT_MASK) >> 8;
- if (likely(type < sizeof(types) && types[type]))
+ if (likely(type < ARRAY_SIZE(types) && types[type]))
return true;
return false;
}
More information about the dri-devel
mailing list