[Bug 39848] New: sensors are inaccessible on radeon X1950 PCIe

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Aug 4 23:47:40 PDT 2011


           Summary: sensors are inaccessible on radeon X1950 PCIe
           Product: DRI
           Version: XOrg CVS
          Platform: Other
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: medium
         Component: DRM/Radeon
        AssignedTo: dri-devel at lists.freedesktop.org
        ReportedBy: thierry.vignaud at gmail.com

My X1950 (RV350) Radeon card has a hw monitoring chip onboard.
I read that it's now possible to access it via the dri framework and the
standard lm-sensors toolkit, and the lm63 is the driver I need.

I ran sensors-detect:

Next adapter: Radeon i2c bit bus 0x92 (i2c-2)
Do you want to scan it? (YES/no/selectively):
Client found at address 0x4c
Probing for `National Semiconductor LM63'...                Success!
    (confidence 6, driver `lm63')
Now follows a summary of the probes I have just done.
Driver `lm63':
  * Bus `Radeon i2c bit bus 0x92'
    Busdriver `UNKNOWN', I2C address 0x4c
    Chip `National Semiconductor LM63' (confidence: 6)

But lm63 doesn't seem to work. Modules load without any error, but if I run
'sensors', only the motherboard sensors are printed.
qFrom dmesg:
i2c /dev entries driver
smsc47b397: found SMSC LPC47B397-NC (base address 0x0900, revision 1)

With kernel 2.6.3x and 3.0
With xserver 1.7, 1.9 & 1.10
with x11 driver 6.14.1 & previous too

$ lspcidrake -v|fgrep VGA
lCard:ATI Radeon X1950 and earlier: ATI Technologies Inc|RV530LE [Radeon
X1600/X1650 PRO] [DISPLAY_VGA] (vendor:1002 device:71c6 subv:174b subd:0880)
$ lspci|fgrep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV530LE [Radeon
X1600/X1650 PRO]

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the dri-devel mailing list