[Bug 34462] 180 second hang on boot, DRM doesn't seem to initialize (firmware issue?)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Feb 18 21:23:15 PST 2011


--- Comment #2 from Owen Riddy <owen.riddy at gmail.com> 2011-02-18 21:23:16 PST ---
Comparing the initrd of 2.6.37 and 2.6.32 show they are both the same, and
neither of them have any firmware in them. They didn't actually have the radeon
module at all.

I compared /lib/firmware to the git repository
http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git , everything
matched (I checked with md5sum) except the newer
BARTS/CAICOS/BTC/PALM/SUMO/TURKS firmware which I assume is all later than my

I tried to force update-initramfs to include the radeon kernel modules by
listing it in /etc/initramfs-tools/modules, but this caused the
update-initramfs to hang when loading radeon.ko in.

Rather than try to insert everything manually in my initrd, I blacklisted
radeon in /etc/modeprobe.d and modprobe'd it in after a complete boot to a
virtual terminal.

On my old kernel, this worked swimmingly (no radeon in lsmod, module loaded
nicely). On the debian stock kernel modprobe hangs, I stopped timing after ten
minutes, the screen doesn't resize as usual for KMS, lsmod lists
radeon/drm/drm_kms_helper. dmesg again shows only RS780 Microcode being loaded.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the dri-devel mailing list