[PATCH 6/6] drm/radeon: Fix the definition of RADEON_BUF_SWAP_32BIT

Alex Deucher alexdeucher at gmail.com
Wed Jul 13 07:47:43 PDT 2011


On Wed, Jul 13, 2011 at 2:28 AM, Benjamin Herrenschmidt
<benh at kernel.crashing.org> wrote:
> (Note that this is duplicated under various other names such
> as R600_BUF_SWAP_32BIT etc...). At least now all the definitions
> agree.
>
> Signed-off-by: Benjamin Herrenschmidt <benh at kernel.crashing.org>

Reviewed-by: Alex Deucher <alexander.deucher at amd.com>

> ---
>
> (resent adding dri-devel to the CC list to hit patchwork)
>
>  drivers/gpu/drm/radeon/radeon_reg.h |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/gpu/drm/radeon/radeon_reg.h b/drivers/gpu/drm/radeon/radeon_reg.h
> index ec93a75..0828add1 100644
> --- a/drivers/gpu/drm/radeon/radeon_reg.h
> +++ b/drivers/gpu/drm/radeon/radeon_reg.h
> @@ -3293,7 +3293,7 @@
>  #      define RADEON_RB_BUFSZ_MASK             (0x3f << 0)
>  #      define RADEON_RB_BLKSZ_SHIFT            8
>  #      define RADEON_RB_BLKSZ_MASK             (0x3f << 8)
> -#      define RADEON_BUF_SWAP_32BIT            (1 << 17)
> +#      define RADEON_BUF_SWAP_32BIT            (2 << 16)
>  #      define RADEON_MAX_FETCH_SHIFT           18
>  #      define RADEON_MAX_FETCH_MASK            (0x3 << 18)
>  #      define RADEON_RB_NO_UPDATE              (1 << 27)
>
>
>
>


More information about the dri-devel mailing list