[PATCH] Drivers: gpu: drm: drm_memory: fixed coding style issue

Ville Syrjälä syrjala at sci.fi
Fri Jun 17 08:12:41 PDT 2011


On Fri, Jun 17, 2011 at 07:38:56PM +1200, Chris Forbes wrote:
> Fixed coding style issues flagged by checkpatch.pl.
> 
> Signed-off-by: Chris Forbes <chrisf at ijw.co.nz>
> ---
>  drivers/gpu/drm/drm_memory.c |   20 +++++++++++---------
>  1 files changed, 11 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_memory.c b/drivers/gpu/drm/drm_memory.c
> index c9b8050..516c86a 100644
> --- a/drivers/gpu/drm/drm_memory.c
> +++ b/drivers/gpu/drm/drm_memory.c
> @@ -57,7 +57,7 @@ int drm_mem_info(char *buf, char **start, off_t offset,
>  
>  #if __OS_HAS_AGP
>  static void *agp_remap(unsigned long offset, unsigned long size,
> -		       struct drm_device * dev)
> +		       struct drm_device *dev)
>  {
>  	unsigned long i, num_pages =
>  	    PAGE_ALIGN(size) / PAGE_SIZE;
> @@ -81,16 +81,18 @@ static void *agp_remap(unsigned long offset, unsigned long size,
>  		return NULL;
>  
>  	/*
> -	 * OK, we're mapping AGP space on a chipset/platform on which memory accesses by
> -	 * the CPU do not get remapped by the GART.  We fix this by using the kernel's
> -	 * page-table instead (that's probably faster anyhow...).
> +	 * OK, we're mapping AGP space on a chipset/platform on which
> +	 * memory accesses by the CPU do not get remapped by the GART.
> +	 * We fix this by using the kernel's page-table instead
> +	 * (that's probably faster anyhow...).
>  	 */
>  	/* note: use vmalloc() because num_pages could be large... */
>  	page_map = vmalloc(num_pages * sizeof(struct page *));
>  	if (!page_map)
>  		return NULL;
>  
> -	phys_page_map = (agpmem->memory->pages + (offset - agpmem->bound) / PAGE_SIZE);
> +	phys_page_map = (agpmem->memory->pages + (offset - agpmem->bound)
> +		/ PAGE_SIZE);

If you feel the need to do this, at least wrap it at '+', otherwise
you're making the order of operations harder to follow. And you might
as well remove the pointless parens while you're at it.

-- 
Ville Syrjälä
syrjala at sci.fi
http://www.sci.fi/~syrjala/


More information about the dri-devel mailing list