[Bug 30812] New: radeon module fails to initialize with modeset=1 on PPC32 with RV280

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Wed Mar 9 05:58:45 PST 2011


           Summary: radeon module fails to initialize with modeset=1 on
                    PPC32 with RV280
           Product: Drivers
           Version: 2.5
    Kernel Version: 2.6.35 to 2.6.38-rc6
          Platform: All
        OS/Version: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Video(DRI - non Intel)
        AssignedTo: drivers_video-dri at kernel-bugs.osdl.org
        ReportedBy: bugzilla_kernel_org at nguyen.vg
        Regression: No

Created an attachment (id=50462)
 --> (https://bugzilla.kernel.org/attachment.cgi?id=50462)
output of dmesg after boot (radeon as module, modeset=0) and rmmod of radeon

Hardware: MacMini G4 (ppc-32).
Graphic adaptor: Radeon 9200 (RV280) probably a 'mac' version.

with modprobe radeon modeset=0, everything works fine. Machine boots normally,
X works, xrandr and Xv too.

with modeset=1, modeprobe never returns and gets stucked durring
More specifically, the call to radeon_fence_wait in r100_ib_test (r100.c) loops
endlessly (or at least for several hours). I'm attaching dmesg of a modified
driver with more printk.

I have tried several combination of putting AGPART/FBCON/RADEON in kernel or as
modules, tried with and without OFFB and so on, same results. Also attaching
output of lspci and .config used for the dmesg trace and output of radeontool
regs '*'.

Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.

Colocation vs. Managed Hosting
A question and answer guide to determining the best fit
for your organization - today and in the future.
Dri-devel mailing list
Dri-devel at lists.sourceforge.net

More information about the dri-devel mailing list