[Bug 31892] New: Problems with nouveau on my HP laptop

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Fri Mar 25 20:04:35 PDT 2011


           Summary: Problems with nouveau on my HP laptop
           Product: Drivers
           Version: 2.5
    Kernel Version: 2.6.38-Linus-07088-gb973a3b
          Platform: All
        OS/Version: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Video(DRI - non Intel)
        AssignedTo: drivers_video-dri at kernel-bugs.osdl.org
        ReportedBy: Larry.Finger at lwfinger.net
        Regression: No

First of all, this is not a complaint. Using 2.6.38-gitX, my laptop works
correctly using the nouveau driver, at least for X. I previously tried it with
the 2.6.37 kernel in openSUSE 11.4. At that point, nothing worked. I
congratulate you on your improvements.

My hardware is given by "sudo lspci -vvv" as

00:12.0 VGA compatible controller: nVidia Corporation C67 [GeForce 7150M /
nForce 630M] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 30d6
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at c0000000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Kernel driver in use: nouveau

The probllems are as follows:

(1) My logs are spammed with lots of

[drm] nouveau 0000:00:12.0: Load detected on output B

There are also the occasional

[drm] nouveau 0000:00:12.0: Setting dpms mode 0 on lvds encoder (output 0)
[drm] nouveau 0000:00:12.0: Calling LVDS script 2:
[drm] nouveau 0000:00:12.0: 0xD6D8: Parsing digital output script table
[drm] nouveau 0000:00:12.0: Calling LVDS script 5:
[drm] nouveau 0000:00:12.0: 0xD676: Parsing digital output script table
[drm] nouveau 0000:00:12.0: Setting dpms mode 0 on TV encoder (output 2)

(2) The fonts in terminals are not really sharp. The screen resolution is set
to 1024x768, not the 1280x800 that is native for the screen. The xrandr command

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 303mm
x 190mm
   1280x800       60.0 +
   1024x768       59.9* 
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8  

The inability to switch to the higher resolution is probably my fault.

The worst problem is that the boot sequence and virtual terminals 1-6 all have
the text covering only the right-hand 2/3 of the screen, and the characters are
not dense as they are with the framebuffer driver I get with the "nomodeset"
option on the GRUB boot line.

Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.

Enable your software for Intel(R) Active Management Technology to meet the
growing manageability and security demands of your customers. Businesses
are taking advantage of Intel(R) vPro (TM) technology - will your software 
be a part of the solution? Download the Intel(R) Manageability Checker 
today! http://p.sf.net/sfu/intel-dev2devmar
Dri-devel mailing list
Dri-devel at lists.sourceforge.net

More information about the dri-devel mailing list