[Bug 42490] NUTMEG DP to VGA bridge not working

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Apr 14 20:00:52 PDT 2012


--- Comment #12 from Jeff Cook <jeff at deserettechnology.com> 2012-04-14 20:00:52 PDT ---
Seeing this here on an Acer Aspire am3470g-uw10p with Radeon HD 6530D. The vga
output dies as soon as radeon with KMS is loaded. In process of acquiring HDMI
cable to test with HDMI output.

I have tried with 3.3.1 and 3.3.2 and same problem. Using xorg 1.12.1,
xf86-video-ati 6.14.4, ati-dri/mesa 8.0.2 on brand new Arch Linux. Also tried
Ubuntu 11.10 Live CD and same results.

Adding vga=775 radeon.modeset=0 to kernel boot line gives me a usable console
interface and Xorg will actually start that way, but Xorg display is highly
corrupted with bands of bright green and red lines.

Ubuntu 12.04 beta 2 gives same result except that it can successfully start a
non-corrupted (but incorrect resolution) Xorg server with the kernel boot line

I have an identical snippet in my dmesg as the one posted by Mandeep Baines

This bug is marked fixed for Ubuntu in Launchpad (
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/825777 ) but it doesn't
work with a fully up-to-date Arch Linux. I haven't had occasion to try the
specific Ubuntu kernel build (3.0.0-17.30) cited as resolving the problem (and
it seems to be based on one positive result) and I don't seem to see a patch
that would be applicable to a mainline kernel.

VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek
[Radeon HD 6530D]

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the dri-devel mailing list