[PATCH] drm: Make the HPD status updates debug logs more readable

Daniel Vetter daniel at ffwll.ch
Tue Dec 4 09:39:41 PST 2012


On Tue, Dec 04, 2012 at 04:00:17PM +0000, Damien Lespiau wrote:
> From: Damien Lespiau <damien.lespiau at intel.com>
> 
> Instead of just printing "status updated from 1 to 2", make those enum
> numbers immediately readable.
> 
> Signed-off-by: Damien Lespiau <damien.lespiau at intel.com>

I like, stupid me can never remember the magic values. For the patch
itself, can you please also patch the connector updates in
drm_helper_probe_single_connector_modes (which is required to avoid losing
hpd events when doing a manual probe cycle) and output_poll_execute. For
completeness maybe also throw in a debug output in
drm_helper_disable_unused_functions, but that's only relevant for drivers
that use the modeset helpers (i.e. not for drm/i915).

Thanks, Daniel

> ---
>  drivers/gpu/drm/drm_crtc_helper.c | 17 +++++++++++++++--
>  1 file changed, 15 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_crtc_helper.c b/drivers/gpu/drm/drm_crtc_helper.c
> index 1fe719f..8b963fd 100644
> --- a/drivers/gpu/drm/drm_crtc_helper.c
> +++ b/drivers/gpu/drm/drm_crtc_helper.c
> @@ -1043,6 +1043,18 @@ void drm_kms_helper_poll_fini(struct drm_device *dev)
>  }
>  EXPORT_SYMBOL(drm_kms_helper_poll_fini);
>  
> +static const char *connector_status_str(enum drm_connector_status status)
> +{
> +	switch (status) {
> +	case connector_status_connected:
> +		return "connected";
> +	case connector_status_disconnected:
> +		return "disconnected";
> +	default:
> +		return "unknown";
> +	}
> +}
> +
>  void drm_helper_hpd_irq_event(struct drm_device *dev)
>  {
>  	struct drm_connector *connector;
> @@ -1062,10 +1074,11 @@ void drm_helper_hpd_irq_event(struct drm_device *dev)
>  		old_status = connector->status;
>  
>  		connector->status = connector->funcs->detect(connector, false);
> -		DRM_DEBUG_KMS("[CONNECTOR:%d:%s] status updated from %d to %d\n",
> +		DRM_DEBUG_KMS("[CONNECTOR:%d:%s] status updated from %s to %s\n",
>  			      connector->base.id,
>  			      drm_get_connector_name(connector),
> -			      old_status, connector->status);
> +			      connector_status_str(old_status),
> +			      connector_status_str(connector->status));
>  		if (old_status != connector->status)
>  			changed = true;
>  	}
> -- 
> 1.7.11.7
> 
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch


More information about the dri-devel mailing list