[PATCH 2/2] drm: add support for private planes

Rob Clark rob at ti.com
Wed Jan 4 20:55:31 PST 2012


note: looks like I need to rebase this patch after exynos drm driver
was pulled to drm-next.. if there are some other consumers that are
waiting to be pulled, let me know and I'll just rebase on top of that.
 (Either way, it would be a trivial merge conflict.. just add FALSE as
additional arg to drm_plane_init())

BR,
-R

On Tue, Dec 13, 2011 at 8:19 PM, Rob Clark <rob.clark at linaro.org> wrote:
> From: Rob Clark <rob at ti.com>
>
> In cases where the scanout hw is sufficiently similar between "overlay"
> and traditional crtc layers, it might be convenient to allow the driver
> to create internal drm_plane helper objects used by the drm_crtc
> implementation, rather than duplicate code between the plane and crtc.
> A private plane is not exposed to userspace.
>
> Signed-off-by: Rob Clark <rob at ti.com>
> ---
>  drivers/gpu/drm/drm_crtc.c |   22 +++++++++++++++++-----
>  include/drm/drm_crtc.h     |    3 ++-
>  2 files changed, 19 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> index 6dad421..d73746e 100644
> --- a/drivers/gpu/drm/drm_crtc.c
> +++ b/drivers/gpu/drm/drm_crtc.c
> @@ -557,7 +557,8 @@ EXPORT_SYMBOL(drm_encoder_cleanup);
>  int drm_plane_init(struct drm_device *dev, struct drm_plane *plane,
>                   unsigned long possible_crtcs,
>                   const struct drm_plane_funcs *funcs,
> -                  uint32_t *formats, uint32_t format_count)
> +                  const uint32_t *formats, uint32_t format_count,
> +                  bool priv)
>  {
>        mutex_lock(&dev->mode_config.mutex);
>
> @@ -576,8 +577,16 @@ int drm_plane_init(struct drm_device *dev, struct drm_plane *plane,
>        plane->format_count = format_count;
>        plane->possible_crtcs = possible_crtcs;
>
> -       list_add_tail(&plane->head, &dev->mode_config.plane_list);
> -       dev->mode_config.num_plane++;
> +       /* private planes are not exposed to userspace, but depending on
> +        * display hardware, might be convenient to allow sharing programming
> +        * for the scanout engine with the crtc implementation.
> +        */
> +       if (!priv) {
> +               list_add_tail(&plane->head, &dev->mode_config.plane_list);
> +               dev->mode_config.num_plane++;
> +       } else {
> +               INIT_LIST_HEAD(&plane->head);
> +       }
>
>        mutex_unlock(&dev->mode_config.mutex);
>
> @@ -592,8 +601,11 @@ void drm_plane_cleanup(struct drm_plane *plane)
>        mutex_lock(&dev->mode_config.mutex);
>        kfree(plane->format_types);
>        drm_mode_object_put(dev, &plane->base);
> -       list_del(&plane->head);
> -       dev->mode_config.num_plane--;
> +       /* if not added to a list, it must be a private plane */
> +       if (!list_empty(&plane->head)) {
> +               list_del(&plane->head);
> +               dev->mode_config.num_plane--;
> +       }
>        mutex_unlock(&dev->mode_config.mutex);
>  }
>  EXPORT_SYMBOL(drm_plane_cleanup);
> diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> index dd55727..1354ef5 100644
> --- a/include/drm/drm_crtc.h
> +++ b/include/drm/drm_crtc.h
> @@ -828,7 +828,8 @@ extern int drm_plane_init(struct drm_device *dev,
>                          struct drm_plane *plane,
>                          unsigned long possible_crtcs,
>                          const struct drm_plane_funcs *funcs,
> -                         uint32_t *formats, uint32_t format_count);
> +                         const uint32_t *formats, uint32_t format_count,
> +                         bool private);
>  extern void drm_plane_cleanup(struct drm_plane *plane);
>
>  extern void drm_encoder_cleanup(struct drm_encoder *encoder);
> --
> 1.7.5.4
>


More information about the dri-devel mailing list