[PATCH 04/14] media: add V4L2 DT binding documentation
g.liakhovetski at gmx.de
Fri Oct 5 04:37:43 PDT 2012
On Fri, 5 Oct 2012, Hans Verkuil wrote:
> On Fri October 5 2012 11:43:27 Guennadi Liakhovetski wrote:
> > On Wed, 3 Oct 2012, Rob Herring wrote:
> > > On 10/02/2012 09:33 AM, Guennadi Liakhovetski wrote:
> > > > Hi Rob
> > > >
> > > > On Tue, 2 Oct 2012, Rob Herring wrote:
> > > >
> > > >> On 09/27/2012 09:07 AM, Guennadi Liakhovetski wrote:
> > > >>> +Optional link properties:
> > > >>> +- remote: phandle to the other endpoint link DT node.
> > > >>
> > > >> This name is a little vague. Perhaps "endpoint" would be better.
> > > >
> > > > "endpoint" can also refer to something local like in USB case. Maybe
> > > > rather the description of the "remote" property should be improved?
> > >
> > > remote-endpoint?
> > Sorry, I really don't want to pull in yet another term here. We've got
> > ports and links already, now you're proposing to also use "endpoind."
> > Until now everyone was happy with "remote," any more opinions on this?
> Actually, when I was reviewing the patch series today I got confused as
> well by 'remote'. What about 'remote-link'?
Yes, I was thinking about this one too, it looks a bit clumsy, but it does
make it clearer, what is meant.
> And v4l2_of_get_remote() can be renamed to v4l2_of_get_remote_link() which
> I think is a lot clearer.
> The text can be improved as well since this:
> - remote: phandle to the other endpoint link DT node.
> is a bit vague. How about:
> - remote-link: phandle to the remote end of this link.
Looks good to me.
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
More information about the dri-devel