[PATCH 1/2 v6] of: add helper to parse display timings

Thierry Reding thierry.reding at avionic-design.de
Sat Oct 20 12:59:51 PDT 2012


On Thu, Oct 04, 2012 at 07:59:19PM +0200, Steffen Trumtrar wrote:
[...]
> diff --git a/include/linux/of_display_timings.h b/include/linux/of_display_timings.h
[...]
> +struct display_timings {
> +	unsigned int num_timings;
> +	unsigned int default_timing;
> +
> +	struct signal_timing **timings;
> +};
> +
> +struct timing_entry {
> +	u32 min;
> +	u32 typ;
> +	u32 max;
> +};
> +
> +struct signal_timing {

I'm slightly confused by the naming here. signal_timing seems overly
generic in this context. Is there any reason why this isn't called
display_timing or even display_mode?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20121020/9a1cb37d/attachment.pgp>


More information about the dri-devel mailing list