[Bug 66963] r600: linux v3.11.0-RC isn't booting with radeon.dpm=1 option in grub

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Sep 29 22:44:17 PDT 2013


--- Comment #136 from Alex Deucher <agd5f at yahoo.com> ---
(In reply to comment #135)
> Created attachment 86825 [details]
> dmesg when under works due to setting .debug=1
> I tried again with the latest rc3 build and it still doesn't work; I had
> left changes from comment 94 intact.  Trying to get more information I tried
> booting with radeon.modeset=0 radeon.debug=1.  Once I re-loaded the module
> with dpm, now it works!  So it works correctly if you set it to debug mode,
> otherwise I can't get any logs of the event.  

There is no radeon.debug parameter:
[   34.991462] radeon: unknown parameter 'debug' ignored

Seems like you just got lucky this time. Does it work reliably if you disable
radeon and boot into a non-X runlevel, then manually load radeon?  E.g., boot
radeon.modeset=0 1
on the kernel command line in grub to boot into single user mode.  then at the
command prompt:
modprobe -r radeon
modprobe radeon modeset=1 dpm=1

> This is the dmesg from when it worked (with debug on).  I noticed there are
> some HDMI errors; I only have DVI actually hooked up.

You can ignore those.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20130930/0f99626b/attachment.html>

More information about the dri-devel mailing list