[Bug 82201] [HAWAII] GPU doesn't reclock, poor 3D performance

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Aug 12 08:47:03 PDT 2014


--- Comment #29 from Kai <kai at dev.carbon-project.org> ---
(In reply to comment #27)
> Not sure if this is useful, but DPM stopped working for me once and was
> stuck at 360MHz. I was doing some testing, Heaven had 60 fps originally and
> after I run it again later, I only got 18 fps. Considering the lowest clocks
> I get with DPM enabled are 300MHz, it wasn't completely underclocked.
> It's definitely different from suspend to RAM, which pretty much disables
> DPM. After suspend to RAM, I always get 280MHz or so. BTW, the same thing
> with suspend to RAM also happens with Bonaire.

@Marek: was that directed at me (I don't think so)? If yes, I'm unsure what I
should derive from your statement and what I should try.

(In reply to comment #28)
> Did you try to "echo auto >
> /sys/class/drm/card0/device/power_dpm_force_performance_level"?
> It may be related to bug #79806 (Performance degradation after resume), that
> should be fixed by patch I've sent to Alex recently.

I've tried it now and get what was described in bug #79806, comment 3:

# echo "auto" > /sys/class/drm/card0/device/power_dpm_force_performance_level 
bash: echo: write error: Invalid argument

Not sure, what valid options would be for me.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140812/e2e2cc95/attachment-0001.html>

More information about the dri-devel mailing list