[PATCH 1/7] drm: Renaming DP training vswing pre emph defines
thierry.reding at gmail.com
Tue Aug 26 04:28:19 PDT 2014
On Fri, Aug 08, 2014 at 04:23:40PM +0530, sonika.jindal at intel.com wrote:
> From: Sonika Jindal <sonika.jindal at intel.com>
> Adding new defines, older one will be removed in the last patch in the series.
> This is to rename the defines to have levels instead of values for vswing and
> pre-emph levels as the values may differ in other scenarios like low vswing of
> eDP1.4 where the values are different.
> Done using following cocci patch for each define:
> # define DP_TRAIN_VOLTAGE_SWING_400 (0 << 0)
> + # define DP_TRAIN_VOLTAGE_SWING_LEVEL_0 (0 << 0)
Could this perhaps be simply:
#define DP_TRAIN_VOLTAGE_SWING(x) ((x) << 0)
As it is, there's no information about the value within the symbolic
name anyway, so _LEVEL_* really isn't that useful and keeping several
macros for each value seems isn't either.
An alternative would be to provide a second set of defines for eDP 1.4
where the name implies the meaning and then use them as appropriate.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 819 bytes
Desc: not available
More information about the dri-devel