[PATCH 1/7] drm: Renaming DP training vswing pre emph defines
jg1.han at samsung.com
Wed Aug 27 17:34:35 PDT 2014
On Wednesday, August 27, 2014 1:31 PM, Jindal, Sonika wrote:
> On 8/26/2014 4:58 PM, Thierry Reding wrote:
> > On Fri, Aug 08, 2014 at 04:23:40PM +0530, sonika.jindal at intel.com wrote:
> >> From: Sonika Jindal <sonika.jindal at intel.com>
> >> Adding new defines, older one will be removed in the last patch in the series.
> >> This is to rename the defines to have levels instead of values for vswing and
> >> pre-emph levels as the values may differ in other scenarios like low vswing of
> >> eDP1.4 where the values are different.
> >> Done using following cocci patch for each define:
> >> @@
> >> @@
> >> # define DP_TRAIN_VOLTAGE_SWING_400 (0 << 0)
> >> + # define DP_TRAIN_VOLTAGE_SWING_LEVEL_0 (0 << 0)
> > Could this perhaps be simply:
> > #define DP_TRAIN_VOLTAGE_SWING(x) ((x) << 0)
> > As it is, there's no information about the value within the symbolic
> > name anyway, so _LEVEL_* really isn't that useful and keeping several
> > macros for each value seems isn't either.
> I feel _LEVEL_* makes it more readable and since there are only 4 values
> possible, it is ok to have 4 different macros for readability purpose.
> What do you think?
(+cc Damien Lespiau)
Personally, I also think that LEVEL_* looks more readable.
> > An alternative would be to provide a second set of defines for eDP 1.4
> > where the name implies the meaning and then use them as appropriate.
> > Thierry
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
More information about the dri-devel