[PATCH 1/7] drm: Renaming DP training vswing pre emph defines
damien.lespiau at intel.com
Thu Aug 28 00:01:51 PDT 2014
On Wed, Aug 27, 2014 at 03:11:08PM +0200, Thierry Reding wrote:
> > So we're left with
> > #define DP_TRAIN_VOLTAGE_SWING_LEVEL_0 (0 << 0)
> > Vs
> > #define DP_TRAIN_VOLTAGE_SWING_LEVEL(x) ((x) << 0)
> > The second variant doesn't really bring much more clarity? Can we just
> > go with the first?
> I think the parameterized version is more convenient, especially if you
> want to use that during training sequences and iterate over the levels.
That's a fair point, but today's code manages to do without that nicety.
I think these kind of refinements could go in series with code actually
using them on top.
> But I don't feel too strongly about it, so either way is fine with me.
Thanks, taking some of your time to provide feedback is always
More information about the dri-devel