[Bug 65963] screen goes blank, Linux hangs - Radeon 7870, Gallium, Glamor

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Aug 30 11:45:45 PDT 2014


--- Comment #21 from paul.woegerer at gmail.com ---
(In reply to comment #20)
> (In reply to comment #19)
> > @Damian, I had the same problems. My configuration is similar to yours:
> > Radeon 7870, Linux 3.16.1, xorg 1.16, MESA 10.3 RC1 (fedora f21 branch).
> > 
> > After consulting https://wiki.archlinux.org/index.php/ATI it tried adding
> > radeon.dpm=0 to my kernel command line as a workaround. It solved the
> > problem. No more lockups. The system is now stable with the above
> > configuration. Clearly this has something to do with the powermanagement
> > changes in MESA and the kernel (there were no lockups with earlier versions
> > of MESA)
> There is no power management code in mesa.  Power management is completely
> self-contained in the kernel.  If you are not getting lockups with dpm
> enabled and an older version of mesa, it may be a mesa issue.

Hmm, sounds like newer versions of MESA trigger a dormant power management
issue in the radeon kernel driver (with certain Pitcairn hardware) ...just

It's a while ago thus I can't tell the exact version of kernel and MESA when I
first observed the behavior. All I can say for sure is that now since using
radeon.dpm=0 I did not experience a single lockup anymore (which is good enough
for me).

Is there a way to build the radeon kernel driver with some additional
debugging/logging that could help you to understand what's going on ?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140830/d58bc14f/attachment.html>

More information about the dri-devel mailing list