[PATCHv3 3/4] hdmi: rename HDMI_AUDIO_CODING_TYPE_EXT_STREAM to _EXT_CT
Hans Verkuil
hverkuil at xs4all.nl
Fri Dec 19 04:14:22 PST 2014
From: Hans Verkuil <hans.verkuil at cisco.com>
As per the suggestion of Thierry Reding rename
HDMI_AUDIO_CODING_TYPE_EXT_STREAM to HDMI_AUDIO_CODING_TYPE_EXT_CT to
be consistent with the CEA-861 spec.
Signed-off-by: Hans Verkuil <hans.verkuil at cisco.com>
---
drivers/video/hdmi.c | 2 +-
include/linux/hdmi.h | 3 ++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/video/hdmi.c b/drivers/video/hdmi.c
index a7c6ae4..1626892 100644
--- a/drivers/video/hdmi.c
+++ b/drivers/video/hdmi.c
@@ -842,7 +842,7 @@ hdmi_audio_coding_type_ext_get_name(enum hdmi_audio_coding_type_ext ctx)
return "Invalid";
switch (ctx) {
- case HDMI_AUDIO_CODING_TYPE_EXT_STREAM:
+ case HDMI_AUDIO_CODING_TYPE_EXT_CT:
return "Refer to CT";
case HDMI_AUDIO_CODING_TYPE_EXT_HE_AAC:
return "HE AAC";
diff --git a/include/linux/hdmi.h b/include/linux/hdmi.h
index d6dea20..d70a457 100644
--- a/include/linux/hdmi.h
+++ b/include/linux/hdmi.h
@@ -215,7 +215,8 @@ enum hdmi_audio_sample_frequency {
};
enum hdmi_audio_coding_type_ext {
- HDMI_AUDIO_CODING_TYPE_EXT_STREAM,
+ /* Refer to Audio Coding Type (CT) field in Data Byte 1 */
+ HDMI_AUDIO_CODING_TYPE_EXT_CT,
/*
* The next three CXT values are defined in CEA-861-E only.
--
2.1.3
More information about the dri-devel
mailing list