[PATCH 0/25] Replace DEFINE_PCI_DEVICE_TABLE macro use
Benoit Taine
benoit.taine at lip6.fr
Fri Jul 18 08:26:47 PDT 2014
We should prefer `const struct pci_device_id` over
`DEFINE_PCI_DEVICE_TABLE` to meet kernel coding style guidelines.
This issue was reported by checkpatch.
A simplified version of the semantic patch that makes this change is as
follows (http://coccinelle.lip6.fr/):
// <smpl>
@@
identifier i;
declarer name DEFINE_PCI_DEVICE_TABLE;
initializer z;
@@
- DEFINE_PCI_DEVICE_TABLE(i)
+ const struct pci_device_id i[]
= z;
// </smpl>
I have 103 patches ready, and will only send a few for you to judge if
it is useful enough, and to prevent from spamming too much.
Thanks.
More information about the dri-devel
mailing list