[PATCH 04/16] drm: Improve on minor type helpers v2

David Herrmann dh.herrmann at gmail.com
Wed Mar 26 11:54:11 PDT 2014


Hi

On Tue, Mar 25, 2014 at 2:18 PM, Thomas Hellstrom <thellstrom at vmware.com> wrote:
> Add a drm_is_legacy() helper, constify argument to drm_is_render_client(),
> and use / change helpers where appropriate.
>
> v2: s/drm_is_legacy/drm_is_legacy_client/ and adapt to new code context.

Could we avoid using "legacy" for the primary node? The node-pointer
is called ->primary and Thierry posted patches to also rename
DRM_MINOR_LEGACY to DRM_MINOR_PRIMARY. The primary node is still the
recommended node for mode-setting, so lets not attribute "legacy" to
them,

Otherwise, patch looks good.

Thanks
David

> Signed-off-by: Thomas Hellstrom <thellstrom at vmware.com>
> Reviewed-by: Brian Paul <brianp at vmware.com>
> ---
>  drivers/gpu/drm/drm_crtc.c |    4 ++--
>  drivers/gpu/drm/drm_fops.c |    6 ++----
>  include/drm/drmP.h         |    7 ++++++-
>  3 files changed, 10 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> index 5fb02d5..bf6ef77 100644
> --- a/drivers/gpu/drm/drm_crtc.c
> +++ b/drivers/gpu/drm/drm_crtc.c
> @@ -1492,7 +1492,7 @@ int drm_mode_getresources(struct drm_device *dev, void *data,
>         mutex_unlock(&file_priv->fbs_lock);
>
>         drm_modeset_lock_all(dev);
> -       if (file_priv->minor->type != DRM_MINOR_LEGACY) {
> +       if (!drm_is_legacy_client(file_priv)) {
>
>                 mode_group = NULL;
>                 list_for_each(lh, &dev->mode_config.crtc_list)
> @@ -2848,7 +2848,7 @@ int drm_mode_getfb(struct drm_device *dev,
>         r->pitch = fb->pitches[0];
>         if (fb->funcs->create_handle) {
>                 if (file_priv->is_master || capable(CAP_SYS_ADMIN) ||
> -                   file_priv->minor->type == DRM_MINOR_CONTROL) {
> +                   drm_is_control_client(file_priv)) {
>                         ret = fb->funcs->create_handle(fb, file_priv,
>                                                        &r->handle);
>                 } else {
> diff --git a/drivers/gpu/drm/drm_fops.c b/drivers/gpu/drm/drm_fops.c
> index 5432a1a..e6cdd0f 100644
> --- a/drivers/gpu/drm/drm_fops.c
> +++ b/drivers/gpu/drm/drm_fops.c
> @@ -232,8 +232,7 @@ static int drm_open_helper(struct inode *inode, struct file *filp,
>         /* if there is no current master make this fd it, but do not create
>          * any master object for render clients */
>         mutex_lock(&dev->struct_mutex);
> -       if (!priv->minor->master && !drm_is_render_client(priv) &&
> -           !drm_is_control_client(priv)) {
> +       if (drm_is_legacy_client(priv) && !priv->minor->master) {
>                 /* create a new master */
>                 priv->minor->master = drm_master_create(priv->minor);
>                 if (!priv->minor->master) {
> @@ -271,8 +270,7 @@ static int drm_open_helper(struct inode *inode, struct file *filp,
>                                 goto out_close;
>                         }
>                 }
> -       } else if (!drm_is_render_client(priv) &&
> -                  !drm_is_control_client(priv)) {
> +       } else if (drm_is_legacy_client(priv)) {
>                 /* get a reference to the master */
>                 priv->master = drm_master_get(priv->minor->master);
>         }
> diff --git a/include/drm/drmP.h b/include/drm/drmP.h
> index f708aa19..5fe3d68 100644
> --- a/include/drm/drmP.h
> +++ b/include/drm/drmP.h
> @@ -1232,7 +1232,7 @@ static inline bool drm_modeset_is_locked(struct drm_device *dev)
>         return mutex_is_locked(&dev->mode_config.mutex);
>  }
>
> -static inline bool drm_is_render_client(struct drm_file *file_priv)
> +static inline bool drm_is_render_client(const struct drm_file *file_priv)
>  {
>         return file_priv->minor->type == DRM_MINOR_RENDER;
>  }
> @@ -1242,6 +1242,11 @@ static inline bool drm_is_control_client(const struct drm_file *file_priv)
>         return file_priv->minor->type == DRM_MINOR_CONTROL;
>  }
>
> +static inline bool drm_is_legacy_client(const struct drm_file *file_priv)
> +{
> +       return file_priv->minor->type == DRM_MINOR_LEGACY;
> +}
> +
>  /******************************************************************/
>  /** \name Internal function definitions */
>  /*@{*/
> --
> 1.7.10.4
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel


More information about the dri-devel mailing list