[Bug 77677] HDMI audio on ati7750 choppy with ALSA multi-channel apps

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri May 2 14:19:26 PDT 2014


--- Comment #20 from Andy Furniss <adf.lists at gmail.com> ---
(In reply to comment #19)

> With mplayer as long as there is video it seems to work OK (20 mins longest
> test so far).

This turned out not to be correct - I was testing with HD video and they do
work - but SD will fail.

I posted to the mplayer list and one of the devs thought it sounded like a
reclocking issue and suggested I try playing audio while running glxgears.

With vblank_mode=0 it does help but not totally cure, the audio progresses
normally as opposed to being mostly stuck, but is still distorted.

Running a nexuiz timedemo, however totally cures it!

So it seems that loading up my system is the way to fix and why my HD vids
worked but failed with UVD.

I have tried disabling cpufreq on_demand and also forcing dpm auto/low/high,
but there is no difference - I need load to make it work.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140502/f965e205/attachment.html>

More information about the dri-devel mailing list