[Bug 75401] vgaswitcheroo doesn't work for AMD Radeon 8870m (possibly due to "wrong" PCI class)

bugzilla-daemon at bugzilla.kernel.org bugzilla-daemon at bugzilla.kernel.org
Fri May 9 05:44:30 PDT 2014


Pali Rohár <pali.rohar at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |pali.rohar at gmail.com

--- Comment #7 from Pali Rohár <pali.rohar at gmail.com> ---
@drill87: I had same problem (Xorg server crashing) when I tried to use
DRI_PRIME on 8690M. I fixed it with updating libdri, mesa, radeon & intel xorg
drivers from git. And then it started working. Also I removed everything in
/etc/X11/xorg.conf and /etc/X11/xorg.conf.d/ and called xrandr
--setprovideroutputsource 1 0 before running DRI_PRIME=1 glxinfo

@Alex Deucher: Why is needed to use acpi "ATRM"? If you still remember
https://bugzilla.kernel.org/show_bug.cgi?id=73901#c9 I needed only to patch
radeon_atpx_handler.c. So my radeon card working fine without "ATRM". When
"ATRM" is used? Or for which functions?

You are receiving this mail because:
You are watching the assignee of the bug.

More information about the dri-devel mailing list