[PATCH V4 5/6] dw-hdmi: add support for multi byte register width access
Andy Yan
andy.yan at rock-chips.com
Fri Nov 7 19:19:42 PST 2014
On 2014年11月07日 19:45, Lucas Stach wrote:
> Am Freitag, den 07.11.2014, 19:35 +0800 schrieb Andy Yan:
>> On rockchip rk3288, only word(32-bit) accesses are
>> permitted for hdmi registers. Byte width access (writeb,
>> readb) generates an imprecise external abort.
>>
>> Signed-off-by: Andy Yan <andy.yan at rock-chips.com>
>> ---
>> drivers/gpu/drm/bridge/dw_hdmi.c | 49 +++++++++++++++++++++++++++++++++++++---
>> 1 file changed, 46 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
>> index df76a8c..9867642 100644
>> --- a/drivers/gpu/drm/bridge/dw_hdmi.c
>> +++ b/drivers/gpu/drm/bridge/dw_hdmi.c
>> @@ -126,19 +126,42 @@ struct dw_hdmi {
> [...]
>> + u32 val;
>> +
>> + if (!of_property_read_u32(np, "reg-io-width", &val)) {
>> + switch (val) {
>> + case 4:
>> + hdmi->write = dw_hdmi_writel;
>> + hdmi->read = dw_hdmi_readl;
>> + hdmi->reg_shift = 2;
>> + break;
>> + default:
>> + hdmi->write = dw_hdmi_writeb;
>> + hdmi->read = dw_hdmi_readb;
>> + hdmi->reg_shift = 0;
>> + break;
>> + }
>> + } else {
>> + hdmi->write = dw_hdmi_writeb;
>> + hdmi->read = dw_hdmi_readb;
>> + hdmi->reg_shift = 0;
>> + }
>>
>> ddc_node = of_parse_phandle(np, "ddc-i2c-bus", 0);
>> if (ddc_node) {
> This should throw an error if the property value in devicetree is not
> recognized. This could be simplified like this:
>
> u32 val = 1;
>
> // this won't touch val if it can't find the property
> of_property_read_u32(np, "reg-io-width", &val)
>
>
> switch (val) {
> case 4:
> hdmi->write = dw_hdmi_writel;
> hdmi->read = dw_hdmi_readl;
> hdmi->reg_shift = 2;
> break;
> case 1:
> hdmi->write = dw_hdmi_writeb;
> hdmi->read = dw_hdmi_readb;
> hdmi->reg_shift = 0;
> break;
> default:
> dev_err(dev, "unrecognized value for reg-io-width");
> // error handling
> }
>
> Also the DT binding doc for this property is missing.
>
> Regards,
> Lucas
thanks for your suggestion, I will take it.
this properity is optional, I will add it to DT binding doc
More information about the dri-devel
mailing list