[RFC] drm: add plane iterator macros

Thierry Reding thierry.reding at gmail.com
Fri Nov 21 08:29:32 PST 2014


On Fri, Nov 21, 2014 at 07:39:11AM -0500, Rob Clark wrote:
> Inspired in part by some cute iterator macros I noticed in i915.  I
> currently have these in drm/msm, but seems like they should be useful
> for others.  Quite possibly other iterators would be useful to add for
> other drivers.
> 
> Signed-off-by: Rob Clark <robdclark at gmail.com>
> ---
> NOTE: to actually merge this, depending on the order this is merged
> vs drm/msm/mdp5 atomic support, these would have to be removed from
> msm_kms.h.
> 
>  include/drm/drm_crtc.h | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> index bc1cc3c..5ea46ec 100644
> --- a/include/drm/drm_crtc.h
> +++ b/include/drm/drm_crtc.h
> @@ -773,6 +773,34 @@ struct drm_plane {
>  	struct drm_plane_state *state;
>  };
>  
> +/* iterate over the planes *currently* attached to a crtc, useful
> + * to apply current state to hw:
> + */
> +#define for_each_plane_on_crtc(_crtc, _plane) \
> +	list_for_each_entry((_plane), &(_crtc)->dev->mode_config.plane_list, head) \
> +		if ((_plane)->state->crtc == (_crtc))

Perhaps throw in a drm_ prefix (for this and the below iterator). Or
maybe rename to something like:

	drm_crtc_for_each_plane()

to make the argument list more intuitive?

> +static inline bool
> +__plane_will_be_attached_to_crtc(struct drm_atomic_state *state,
> +		struct drm_plane *plane, struct drm_crtc *crtc)
> +{
> +	int idx = drm_plane_index(plane);
> +
> +	/* if plane is modified in incoming state, use the new state: */
> +	if (state->plane_states[idx])
> +		return state->plane_states[idx]->crtc == crtc;
> +
> +	/* otherwise, current state: */
> +	return plane->state->crtc == crtc;
> +}

Maybe drm_crtc_plane_pending(crtc, state, plane) for somewhat more
cohesive naming?

> +
> +/* iterate over the planes that *will be* attached to a crtc,
> + * useful for ->atomic_check() operations:
> + */
> +#define for_each_pending_plane_on_crtc(_state, _crtc, _plane) \
> +	list_for_each_entry((_plane), &(_crtc)->dev->mode_config.plane_list, head) \
> +		if (__plane_will_be_attached_to_crtc((_state), (_plane), (_crtc)))

Similarily as for the above, perhaps:

	drm_crtc_for_each_pending_plane(_crtc, _state, _plane)

might be more intuitive.

Irrespective of the bike-shedding and with Daniel's comments addressed,
this is:

Reviewed-by: Thierry Reding <treding at nvidia.com>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20141121/352435c6/attachment.sig>


More information about the dri-devel mailing list