[PATCH 4/4] drm/sti: atomic crtc/plane update
Daniel Vetter
daniel at ffwll.ch
Fri Jul 31 06:45:58 PDT 2015
On Fri, Jul 31, 2015 at 12:13:27PM +0200, Vincent Abriou wrote:
> static struct drm_crtc_helper_funcs sti_crtc_helper_funcs = {
> .dpms = sti_crtc_dpms,
dpms isn't needed any more with atomic, you should use
drm_atomic_helper_connector_dpms instead of drm_helper_connector_dpms.
> - .prepare = sti_crtc_prepare,
> - .commit = sti_crtc_commit,
> + .prepare = sti_crtc_helper_prepare,
prepare is now called .enable for clarity.
> + .commit = sti_crtc_helper_commit,
commit and disable are redundant with atomic.
Cheers, Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
More information about the dri-devel
mailing list