[PULL] topic/drm-misc

Daniel Vetter daniel.vetter at ffwll.ch
Wed May 27 23:40:31 PDT 2015


Hi Dave,

One more round of drm-misc, again mostly atomic. Big thing is the
userspace blob code from Daniel Stone, with support for the mode_id blob
now added to the atomic ioctl. Finally we can do atomic modesets!

Note that the atomic ioctl is still behind the module knob since the
weston patches aren't quite ready yet imo - they lack TEST_ONLY support,
which is a fairly crucial bit of the atomic api. But besides that I think
it's all good to go. That's also why we didn't bother to hide the new blob
ioctls behind the knob, that part won't need to change. And if weston
patches get in shape in time we could throw the "atomic by default patch"
on top for 4.2.

Cheers, Daniel


The following changes since commit bdcddf95e82b1c4e370fc1196b1f4f50f775dab4:

  Backmerge v4.1-rc4 into into drm-next (2015-05-20 16:23:53 +1000)

are available in the git repository at:

  git://anongit.freedesktop.org/drm-intel tags/topic/drm-misc-2015-05-27

for you to fetch changes up to 5ceecb2fa720c01a97e6fa2353c2b8f1e8d69f1f:

  drm: Fix off-by-one in vblank hardware counter wraparound handling (2015-05-27 13:00:08 +0200)

----------------------------------------------------------------
Andrey Ryabinin (1):
      drm/atomic: fix out of bounds read in for_each_*_in_state helpers

Archit Taneja (2):
      drm: bridge: Allow daisy chaining of bridges
      drm/DocBook: Add more drm_bridge documentation

Daniel Stone (11):
      drm: kerneldoc fixes for blob properties
      drm/crtc_helper: Replace open-coded CRTC state helpers
      drm/mode: Validate modes inside drm_crtc_convert_umode
      drm/mode: Unstatic kernel-userspace mode conversion
      drm: Allow creating blob properties without copy
      drm: Return error value from blob creation
      drm/mode: Add user blob-creation ioctl
      drm: Retain reference to blob properties in lookup
      drm: Add drm_atomic_set_mode_for_crtc
      drm/atomic: Add current-mode blob to CRTC state
      drm/atomic: Add MODE_ID property

Daniel Vetter (1):
      drm: check for garbage in unused addfb2 fields

Maarten Lankhorst (3):
      drm/atomic: add commit_planes_on_crtc helper
      drm/atomic: add drm_atomic_add_affected_planes
      drm/atomic: add all affected planes in drm_atomic_helper_check_modeset

Michel Dänzer (1):
      drm: Fix off-by-one in vblank hardware counter wraparound handling

 Documentation/DocBook/drm.tmpl      |  12 ++
 drivers/gpu/drm/drm_atomic.c        | 162 ++++++++++++++++++-
 drivers/gpu/drm/drm_atomic_helper.c | 117 ++++++++++----
 drivers/gpu/drm/drm_bridge.c        | 242 ++++++++++++++++++++++++++++
 drivers/gpu/drm/drm_crtc.c          | 304 ++++++++++++++++++++++++------------
 drivers/gpu/drm/drm_crtc_helper.c   | 101 +++++-------
 drivers/gpu/drm/drm_fops.c          |   5 +-
 drivers/gpu/drm/drm_ioctl.c         |   2 +
 drivers/gpu/drm/drm_irq.c           |   4 +-
 drivers/gpu/drm/drm_modes.c         |  87 +++++++++++
 include/drm/drmP.h                  |   4 +
 include/drm/drm_atomic.h            |  34 ++--
 include/drm/drm_atomic_helper.h     |   1 +
 include/drm/drm_crtc.h              |  27 +++-
 include/drm/drm_modes.h             |   4 +
 include/uapi/drm/drm.h              |   2 +
 include/uapi/drm/drm_mode.h         |  20 +++
 17 files changed, 923 insertions(+), 205 deletions(-)

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch


More information about the dri-devel mailing list