[PATCH] drm: probe_helper: Hide ugly ifdef
Jani Nikula
jani.nikula at linux.intel.com
Wed Apr 20 09:24:16 UTC 2016
On Tue, 19 Apr 2016, Ezequiel Garcia <ezequiel at vanguardiasur.com.ar> wrote:
> Push the ifdef to the drm_edid.h and create a stub, for the
> DRM_LOAD_EDID_FIRMWARE=n case. This removes some clutter in
> the code, making it more readable.
>
> Signed-off-by: Ezequiel Garcia <ezequiel at vanguardiasur.com.ar>
Reviewed-by: Jani Nikula <jani.nikula at intel.com>
> ---
> drivers/gpu/drm/drm_probe_helper.c | 2 --
> include/drm/drm_edid.h | 8 ++++++++
> 2 files changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_probe_helper.c b/drivers/gpu/drm/drm_probe_helper.c
> index e714b5a7955f..0329080d7f7c 100644
> --- a/drivers/gpu/drm/drm_probe_helper.c
> +++ b/drivers/gpu/drm/drm_probe_helper.c
> @@ -264,10 +264,8 @@ int drm_helper_probe_single_connector_modes(struct drm_connector *connector,
> count = drm_add_edid_modes(connector, edid);
> drm_edid_to_eld(connector, edid);
> } else {
> -#ifdef CONFIG_DRM_LOAD_EDID_FIRMWARE
> count = drm_load_edid_firmware(connector);
> if (count == 0)
> -#endif
> count = (*connector_funcs->get_modes)(connector);
> }
>
> diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> index 2af97691e878..5996598bc778 100644
> --- a/include/drm/drm_edid.h
> +++ b/include/drm/drm_edid.h
> @@ -328,7 +328,15 @@ int drm_edid_to_speaker_allocation(struct edid *edid, u8 **sadb);
> int drm_av_sync_delay(struct drm_connector *connector,
> const struct drm_display_mode *mode);
> struct drm_connector *drm_select_eld(struct drm_encoder *encoder);
> +
> +#ifdef CONFIG_DRM_LOAD_EDID_FIRMWARE
> int drm_load_edid_firmware(struct drm_connector *connector);
> +#else
> +static inline int drm_load_edid_firmware(struct drm_connector *connector)
> +{
> + return 0;
> +}
> +#endif
>
> int
> drm_hdmi_avi_infoframe_from_display_mode(struct hdmi_avi_infoframe *frame,
--
Jani Nikula, Intel Open Source Technology Center
More information about the dri-devel
mailing list