[PATCH 00/12] drm/atomic: Rename async to nonblocking.

Maarten Lankhorst maarten.lankhorst at linux.intel.com
Tue Apr 26 14:11:33 UTC 2016


Userspace calls the atomic ioctl with DRM_MODE_ATOMIC_NONBLOCK
when it doesn't want the ioctl to block for completion.

In the kernel it's called async commit, which is confusing. The legacy
pageflip and atomic ioctl also have a flag DRM_MODE_PAGE_FLIP_ASYNC
which means that the flip should happen as soon as possible,
even if it causes tearing.

Because of this we should rename async commit to nonblocking commit,
which should reduce a lot of the confusion.

This is done partially with a cocci script, and inspection by hand
because cocci doesn't patch comments.

Maarten Lankhorst (12):
  drm/atomic: Rename async parameter to nonblocking.
  drm/atomic: Rename drm_atomic_async_commit to nonblocking.
  drm/arm/hdlcd: Rename async to nonblock.
  drm/exynos: Rename async to nonblock.
  drm/msm: Rename async to nonblock.
  drm/omapdrm: Rename async to nonblock.
  drm/rcar-du: Rename async to nonblock.
  drm/sti: Rename async to nonblock.
  drm/tegra: Rename async to nonblock.
  drm/rockchip: Rename async to nonblock.
  drm/vc4: Rename async to nonblock.
  drm/i915: Rename async to nonblock.

 drivers/gpu/drm/arm/hdlcd_drv.c            |  2 +-
 drivers/gpu/drm/drm_atomic.c               | 12 +++++------
 drivers/gpu/drm/drm_atomic_helper.c        | 34 +++++++++++++++---------------
 drivers/gpu/drm/exynos/exynos_drm_drv.c    |  4 ++--
 drivers/gpu/drm/exynos/exynos_drm_drv.h    |  2 +-
 drivers/gpu/drm/i915/intel_display.c       | 16 +++++++-------
 drivers/gpu/drm/msm/msm_atomic.c           |  9 ++++----
 drivers/gpu/drm/msm/msm_drv.h              |  2 +-
 drivers/gpu/drm/omapdrm/omap_drv.c         |  4 ++--
 drivers/gpu/drm/rcar-du/rcar_du_kms.c      |  5 +++--
 drivers/gpu/drm/rockchip/rockchip_drm_fb.c |  6 +++---
 drivers/gpu/drm/sti/sti_drv.c              |  6 +++---
 drivers/gpu/drm/tegra/drm.c                |  6 +++---
 drivers/gpu/drm/vc4/vc4_kms.c              |  6 +++---
 include/drm/drm_atomic.h                   |  2 +-
 include/drm/drm_atomic_helper.h            |  2 +-
 include/drm/drm_crtc.h                     |  8 +++----
 17 files changed, 63 insertions(+), 63 deletions(-)

-- 
2.5.5



More information about the dri-devel mailing list