[PATCH 00/10] libdrm amdgpu patches
Marek Olšák
maraeo at gmail.com
Tue Jan 12 13:23:46 PST 2016
Hi,
These are libdrm_amdgpu patches harvested from an internal branch.
The first patch is a revert I had to make to fix the build. Yeah, sequence_mutex should be renamed to a more appropriate name. That can be done as a follow-up.
One notable change is the addition of DRM_IOCTL_AMDGPU_WAIT_FENCES. I hope the kernel contains (or will contain) the changes too, so that I don't push something that doesn't exist in the kernel.
Please let me know if these are okay to push.
Thanks,
Chunming Zhou (3):
amdgpu: add semaphore support
tests/amdgpu: add semaphore test
amdgpu: validate user memory for userptr
Junwei Zhang (3):
amdgpu: add the interface of waiting multiple fences
amdgpu/tests: add multi-fence test in base test
amdgpu: list each entry safely for sw semaphore when submit ib
Marek Olšák (1):
Revert "amdgpu: remove sequence mutex"
Michel Dänzer (1):
amdgpu: Cast pointer to uintptr_t for assignment to unsigned integer
monk.liu (2):
amdgpu: drop address patching logics
amdgpu: cs_wait_fences now can return the first signaled fence index
amdgpu/amdgpu.h | 88 +++++++++++++++++++++++++++++++++++++++++
amdgpu/amdgpu_bo.c | 14 ++-----
amdgpu/amdgpu_cs.c | 253 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++--
amdgpu/amdgpu_internal.h | 15 +++++++
include/drm/amdgpu_drm.h | 28 +++++++++++++
tests/amdgpu/basic_tests.c | 233 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
6 files changed, 616 insertions(+), 15 deletions(-)
Marek
More information about the dri-devel
mailing list