[PATCH 5/5] drm/radeon: use kobj_to_dev()

Alex Deucher alexdeucher at gmail.com
Wed Jan 13 09:17:14 PST 2016


On Wed, Jan 13, 2016 at 9:48 AM, Geliang Tang <geliangtang at 163.com> wrote:
> Use kobj_to_dev() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang at 163.com>

Applied patches 4 and 5.  thanks!

Alex

> ---
>  drivers/gpu/drm/radeon/radeon_pm.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c
> index 59abebd..460c8f2 100644
> --- a/drivers/gpu/drm/radeon/radeon_pm.c
> +++ b/drivers/gpu/drm/radeon/radeon_pm.c
> @@ -713,7 +713,7 @@ static struct attribute *hwmon_attributes[] = {
>  static umode_t hwmon_attributes_visible(struct kobject *kobj,
>                                         struct attribute *attr, int index)
>  {
> -       struct device *dev = container_of(kobj, struct device, kobj);
> +       struct device *dev = kobj_to_dev(kobj);
>         struct radeon_device *rdev = dev_get_drvdata(dev);
>         umode_t effective_mode = attr->mode;
>
> --
> 2.5.0
>
>
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel


More information about the dri-devel mailing list