[PATCH 2/4] drm/msm/hdmi: Use more DT friendly GPIO names
Rob Herring
robh at kernel.org
Wed Jul 13 13:45:55 UTC 2016
On Fri, Jul 08, 2016 at 11:25:52AM +0530, Archit Taneja wrote:
> Update the gpio name parsing code to try to search for without the
> "qcom,hdmi-tx-" prefix. The older downstream bindings that expect
> "qcom,hdmi-tx-xyz" or "qcom,hdmi-tx-xyz-gpio" would work as the
> property name would work as before.
Why?
> Update the binding doc. Add an entry for the missing hpd and lpm
> gpios.
>
> Cc: Rob Herring <robh at kernel.org>
> Cc: devicetree at vger.kernel.org
>
> Signed-off-by: Archit Taneja <architt at codeaurora.org>
> ---
> Documentation/devicetree/bindings/display/msm/hdmi.txt | 6 ++++--
> drivers/gpu/drm/msm/hdmi/hdmi.c | 16 ++++++++++++++++
> 2 files changed, 20 insertions(+), 2 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/display/msm/hdmi.txt b/Documentation/devicetree/bindings/display/msm/hdmi.txt
> index b63f614..4da1abd 100644
> --- a/Documentation/devicetree/bindings/display/msm/hdmi.txt
> +++ b/Documentation/devicetree/bindings/display/msm/hdmi.txt
> @@ -23,8 +23,10 @@ Required properties:
> - phy-names: the name of the corresponding PHY device
>
> Optional properties:
> -- qcom,hdmi-tx-mux-en-gpio: hdmi mux enable pin
> -- qcom,hdmi-tx-mux-sel-gpio: hdmi mux select pin
> +- hpd-gpio: hdmi hpd pin
hpd-gpios is the somewhat standard name.
> +- mux-en-gpio: hdmi mux enable pin
> +- mux-sel-gpio: hdmi mux select pin
> +- mux-lpm-gpio: hdmi mux lpm pin
These look pretty QCom specific and should keep the vendor prefix.
I understand why you don't have '-gpios', but if we change these they
should use the preferred form.
Rob
More information about the dri-devel
mailing list