[PATCH v2 03/10] dt-bindings: msm/mdp: Fix up clock related bindings
Archit Taneja
architt at codeaurora.org
Fri Jun 10 10:46:33 UTC 2016
MDP5:
- Don't ask for source clock
MDP4:
- Give a better name for MDP_TV_CLK
- Remove TV_SRC
- Add MDP_AXI_CLK
Signed-off-by: Archit Taneja <architt at codeaurora.org>
---
Documentation/devicetree/bindings/display/msm/mdp.txt | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/Documentation/devicetree/bindings/display/msm/mdp.txt b/Documentation/devicetree/bindings/display/msm/mdp.txt
index a214f6c..1d3d79d 100644
--- a/Documentation/devicetree/bindings/display/msm/mdp.txt
+++ b/Documentation/devicetree/bindings/display/msm/mdp.txt
@@ -13,14 +13,13 @@ Required properties:
For MDP4:
* "core_clk"
* "iface_clk"
+ * "bus_clk"
* "lut_clk"
- * "src_clk"
* "hdmi_clk"
- * "mdp_clk"
+ * "tv_clk"
For MDP5:
* "bus_clk"
* "iface_clk"
- * "core_clk_src"
* "core_clk"
* "lut_clk" (some MDP5 versions may not need this)
* "vsync_clk"
@@ -45,14 +44,13 @@ Example:
"core_clk",
"iface_clk",
"lut_clk",
- "src_clk",
"hdmi_clk",
"mdp_clk";
clocks =
- <&mmcc MDP_SRC>,
+ <&mmcc MDP_CLK>,
<&mmcc MDP_AHB_CLK>,
+ <&mmcc MDP_AXI_CLK>,
<&mmcc MDP_LUT_CLK>,
- <&mmcc TV_SRC>,
<&mmcc HDMI_TV_CLK>,
<&mmcc MDP_TV_CLK>;
};
--
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
hosted by The Linux Foundation
More information about the dri-devel
mailing list