[Bug 104248] Black screen after switching refresh rate from 144 Hz

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Dec 13 19:26:07 UTC 2017


            Bug ID: 104248
           Summary: Black screen after switching refresh rate from 144 Hz
           Product: DRI
           Version: XOrg git
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: DRM/AMDgpu
          Assignee: dri-devel at lists.freedesktop.org
          Reporter: thomas-lange2 at gmx.de

Created attachment 136148
  --> https://bugs.freedesktop.org/attachment.cgi?id=136148&action=edit
Output of dmesg

My monitor supports 144 Hz as refresh rate which works fine. But switching from
144 Hz to a lower value (like 120 Hz) always results in a black screen with no

The intention is to use 144 Hz for games and 120 Hz on the desktop. PowerPlay
doesn't work with 144 Hz, so the GPU wastes energy and gets hotter than

Switching between other rates (like 120 -> 60 -> 100 -> 60 -> 120) works fine.
It also worked correctly with previous cards (HD4830 and HD6850).

The workaround is to stay on 120 Hz all the time. When the screen shows no
signal, resuming from standby brings it back.

Things I have tried so far:
1. Disabling DPM with "echo high > /sys/class/drm/card0/device/power_profile"
-> Same results

2. Using Linux 4.15-RC3 with enabled DC (amdgpu.dc=1)
-> Refresh rates higher than 60 Hz are not supported
-> Is this known or should I file a separate bug report?

PowerColor RX 560 (POLARIS 11)
LG Electronics 24GM77-B, connected via DVI cable

Linux 4.14.5 x86_64
Mesa 17.2.6
Xorg 1.19.5
xf86-video-amdgpu 1.4.0

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20171213/643ef127/attachment.html>

More information about the dri-devel mailing list