[PATCH] drm: Silence the compiler for drm_mode_get_hv_timings()
Daniel Vetter
daniel at ffwll.ch
Thu Jan 26 15:54:37 UTC 2017
On Thu, Jan 26, 2017 at 02:46:55PM +0200, Ville Syrjälä wrote:
> On Thu, Jan 26, 2017 at 11:44:09AM +0000, Chris Wilson wrote:
> > Since moving drm_crtc_get_hv_timings() into drm_modes.c, the compiler
> > has been able to get smarter and spots that drm_mode_copy() is trying to
> > preserve garbage from the stack.
> >
> > Fixes: 196cd5d3758c ("drm: s/drm_crtc_get_hv_timings/drm_mode_get_hv_timings/")
> > Signed-off-by: Chris Wilson <chris at chris-wilson.co.uk>
> > Cc: Daniel Vetter <daniel.vetter at intel.com>
> > Cc: Alex Deucher <alexander.deucher at amd.com>
>
> Reviewed-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
Could have directly pushed to drm-misc-next ... *hint*
Thanks for patch&review, applied.
-Daniel
>
> > ---
> > drivers/gpu/drm/drm_modes.c | 3 +--
> > 1 file changed, 1 insertion(+), 2 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c
> > index 73ed6399c3fb..a8616b1a8d22 100644
> > --- a/drivers/gpu/drm/drm_modes.c
> > +++ b/drivers/gpu/drm/drm_modes.c
> > @@ -808,9 +808,8 @@ EXPORT_SYMBOL(drm_mode_vrefresh);
> > void drm_mode_get_hv_timing(const struct drm_display_mode *mode,
> > int *hdisplay, int *vdisplay)
> > {
> > - struct drm_display_mode adjusted;
> > + struct drm_display_mode adjusted = *mode;
> >
> > - drm_mode_copy(&adjusted, mode);
> > drm_mode_set_crtcinfo(&adjusted, CRTC_STEREO_DOUBLE_ONLY);
> > *hdisplay = adjusted.crtc_hdisplay;
> > *vdisplay = adjusted.crtc_vdisplay;
> > --
> > 2.11.0
> >
> > _______________________________________________
> > dri-devel mailing list
> > dri-devel at lists.freedesktop.org
> > https://lists.freedesktop.org/mailman/listinfo/dri-devel
>
> --
> Ville Syrjälä
> Intel OTC
> _______________________________________________
> dri-devel mailing list
> dri-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
More information about the dri-devel
mailing list