[PATCH RFC v3] drm: Add properties to control YCbCr to RGB conversion

Jyri Sarha jsarha at ti.com
Mon May 15 11:19:08 UTC 2017


Changes since v2 RFC version:
 - Drop the second patch that exposed the raw CSC and preoffset vector
 - Rename YCBCR_ENCODING to COLOR_ENCODING, add YCbCr to enum values instead
 - Split the encoding and used value range to different properties:
   COLOR_ENCODING and COLOR_RANGE

The v2 RFC and the related discussion can be found here:
http://www.spinics.net/lists/dri-devel/msg140329.html

Jyri Sarha (1):
  drm: Add optinal COLOR_ENCODING and COLOR_RANGE properties to
    drm_plane

 drivers/gpu/drm/drm_atomic.c     |  8 ++++
 drivers/gpu/drm/drm_color_mgmt.c | 97 ++++++++++++++++++++++++++++++++++++++++
 drivers/gpu/drm/drm_plane.c      |  6 +++
 include/drm/drm_color_mgmt.h     | 20 +++++++++
 include/drm/drm_plane.h          |  8 ++++
 5 files changed, 139 insertions(+)

-- 
1.9.1



More information about the dri-devel mailing list